Outlook 2010 - IMAP server closed the connection

If you are having a problem with Yahoo IMAP Connector, ask about it here.

Outlook 2010 - IMAP server closed the connection

Postby TheHammer » Sat Dec 25, 2010 12:20 pm

I have 1.0.4.0 install as a trial.

I'm using Outlook 2010 on a Windows 7 x64 box.

Several times a day I get this message:

"Your IMAP server closed the connection."

When I click Send/Receive in Outlook it successfully talks to my Yahoo Mail account.

Having this message appear multiple times per day is very annoying.

Can you fix the connector so that this message stops appearing?
TheHammer
 
Posts: 2
Joined: Sat Dec 25, 2010 12:15 pm

Re: Outlook 2010 - IMAP server closed the connection

Postby bravurasoft » Sun Dec 26, 2010 11:03 pm

We've seen this problem before. What is happening is Outlook tries to leave a connection to the Yahoo IMAP servers open, but for bandwidth reasons, the Yahoo IMAP servers will close the connection if it's been idle for a couple minutes. Normally, Yahoo IMAP Connector does try to work around this issue with the Yahoo IMAP servers, but it doesn't work for 100% of the cases, so in some of these cases Outlook will show you an error.

Most other email clients won't show the user this error message, but Outlook is simply too verbose.

We will look into ways of working around this problem for the next revision of Yahoo IMAP Connector. Fortunately, this error will sometimes crop up for a day or two, then go away for weeks at a time.
User avatar
bravurasoft
Site Admin
 
Posts: 37
Joined: Thu Sep 09, 2010 10:15 pm
Location: Redmond, WA

Re: Outlook 2010 - IMAP server closed the connection

Postby TheHammer » Thu Dec 30, 2010 9:28 am

When do you think a new version will be available that will try to fix this issue with Outlook 2010?
TheHammer
 
Posts: 2
Joined: Sat Dec 25, 2010 12:15 pm

Re: Outlook 2010 - IMAP server closed the connection

Postby richardturnbull » Thu Dec 30, 2010 4:58 pm

I get this VERY frequently, ie every half hour or so, quite annoying! Otherwise the connector works well thanks! Look forward to a release thats stops this happening.
richardturnbull
 
Posts: 2
Joined: Thu Dec 30, 2010 4:54 pm

Re: Outlook 2010 - IMAP server closed the connection

Postby bravurasoft » Sun Jan 02, 2011 5:30 pm

Unfortunately, this really is more of an Outlook 2010 problem than Yahoo IMAP Connector. If you use Outlook 2010 with pretty much any IMAP server (e.g. Gmail), you will see this error message from time to time. Outlook thinks that it can leave a connection open to the server for any period of time, and that the server won't try to close it if it's been idle for too long. Pretty much every other email client doesn't show an error message in this case, but Outlook is too verbose.

We will look into working around this problem with Outlook, but I can't give you a concrete date yet for a workaround.
User avatar
bravurasoft
Site Admin
 
Posts: 37
Joined: Thu Sep 09, 2010 10:15 pm
Location: Redmond, WA

Re: Outlook 2010 - IMAP server closed the connection

Postby andsoitiswritten » Fri Jan 21, 2011 6:04 am

I thought you should be aware that this happens to me in Outlook 2007 as well so its not limited to the 2010 version.
andsoitiswritten
 
Posts: 1
Joined: Fri Jan 21, 2011 6:02 am

Re: Outlook 2010 - IMAP server closed the connection

Postby coldpenguin » Thu Feb 24, 2011 10:41 am

Don't suppose there is any update to this problem?
It is almost more irritating than using the IMAP connection without the Bravura software.
Reducing my timeout to 10 seconds has made it occur less, but it is still disrupting my work when it occurs.
(in case anyone wonders, the error message is pulling up my task bar, which reduces the total workspace available, and hides some options that I use)
coldpenguin
 
Posts: 1
Joined: Thu Feb 24, 2011 10:36 am

Re: Outlook 2010 - IMAP server closed the connection

Postby bravurasoft » Mon Mar 28, 2011 9:55 pm

OK, thanks for bearing with us - we've got a solution to this error message that you have been experiencing with Outlook 2007 and Outlook 2010.

This is fixed for version 1.0.6 of Yahoo IMAP Connector.
To get the fix, please exit Yahoo IMAP Connector, and download and install the latest version from http://www.bravurasoftware.com/yahoo-im ... oadYIC.htm

You can also get the fix by exiting Yahoo IMAP Connector, and selecting Start Menu > All Programs > Yahoo IMAP Connector > Get Updates

The fix has worked well for us in our testing but if anyone is still encountering this error message after updating to the latest version, please let us know by posting to this forum, or by email at customer_support@bravurasoftware.com
User avatar
bravurasoft
Site Admin
 
Posts: 37
Joined: Thu Sep 09, 2010 10:15 pm
Location: Redmond, WA


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron